PAPOK.RU

...развлекательный портал

  • Увеличить размер шрифта
  • Размер шрифта по умолчанию
  • Уменьшить размер шрифта

Установка ionCube Loader в CENTOS x64

E-mail Печать PDF

Первое, что нужно знать, IonCube Loader можно установить просто написав команду:

yum install php-ioncube-loader

НО, способ не всегда работает, так как в базовых репозиториях не всегда есть нужные пакеты.

Потому идем чуть долгим, но рабочим путем:

 

Устанавливаем IonCube Loader в ручном режиме на сервер под управлением CentOS.

Вначале заходим на официальный сайт лоадера, и выбираем нужный нам пакет, согласно архитектуры системы: http://www.ioncube.com/loaders.php кто сомневается и\или не знает что нужно брать, берите пакет для всех платформ: http://downloads2.ioncube.com/loader_downloads/ioncube_loaders_all_platforms.tar.gz

Далее все просто, берем Putty, входим на сервер и пишем и вытаскием выбранный пакет:

wget http://downloads2.ioncube.com/loader_downloads/ioncube_loaders_all_platforms.tar.gz

(Я для CENTOS 6.4 x86-64 качал командой: wget http://downloads2.ioncube.com/loader_downloads/ioncube_loaders_lin_x86-64.tar.gz)

Распаковываем его:

tar zxf ioncube_loaders_all_platforms.tar.gz

(В моем случае: tar zxvf  ioncube_loaders_lin_x86-64.tar.gz)

Перемещаем в папку  /usr/lib64/php/modules необходимый .so:

cp ioncube/ioncube_loader_lin_5.3.so /usr/lib64/php/modules/

(Обратите внимание, что версия php должна соответствовать цифрам на конце so-шек)

Далее нужно отредактировать php.ini

Кто не знает, где его найти, и\или установлено несколько версий php на сервере, создается файл c содержанием <? phpinfo() ?> и кладется куда-либо, что бы был доступ из веб. Далее смотрим какой файл php.ini использует наш сервер через "морду"браузера.

Мой файл вполне стандартен: /etc/php.ini

Открываем его через nano (или любой другой консольный текстовый редактор) и после строчек Zend*a (если таковой установлен, само-собой), вставляем:

zend_extension = /usr/lib64/php/modules/ioncube_loader_lin_5.3.so

(Обратите внимание, что версия php должна соответствовать цифрам на конце so-шек)

 

, далее просто нужно перезагрузить Apache с новыми настройками:

/etc/init.d/httpd restart

Проверить корректность установки можно запросив версию PHP:

php -v

Должно быть что то подобное:

Поздравляю, теперь на Вашем сервере стоит поддержка IonCube Loader.

Комментарии
Добавить новый Поиск
Оставить комментарий
Имя:
Email:
 
Веб-сайт:
Тема:
UBB-Код:
[b] [i] [u] [url] [quote] [code] [img] 
 
 
:angry::0:confused::cheer:B):evil::silly::dry::lol::kiss::D:pinch:
:(:shock::X:side::):P:unsure::woohoo::huh::whistle:;):s
:!::?::idea::arrow:
 
Пожалуйста, введите проверочный код, который Вы видите на картинке.
Русская редакция: www.freedom-ru.net & www.joobb.ru

3.26 Copyright (C) 2008 Compojoom.com / Copyright (C) 2007 Alain Georgette / Copyright (C) 2006 Frantisek Hliva. All rights reserved."

Обновлено 01.04.2013 12:38  

Голосование

Какой мобильный выбрать?
 

Сайты друзей

Сейчас на сайте

Сейчас 94 гостей онлайн

naviru.ru